概要
メッシュ ポリゴンや市区町村ポリゴンのような隣り合ったポリゴンの枠線からラインを作成する方法を紹介します。
作成方法は以下の 3 通りの方法があります。
- Advanced ライセンスの場合
- Basic ライセンスの場合
・ポリゴンをコピーして、ラインに貼り付ける方法
・[インターセクト] ツール、[ディゾルブ] ツールを使用する方法 - 「サンプル ジオプロセシング ツール」を使用する場合

操作手順
Advanced ライセンスの場合
ArcGIS Pro の [ポリゴン → ライン] ツールを使用してポリゴンからラインを作成します。
- [解析] タブ → [ツール] をクリックして [ジオプロセシング] ウィンドウを表示します。

- [ジオプロセシング] ウィンドウ上部にある [ツールの検索] で「ポリゴン → ライン」と検索し、[ポリゴン → ライン] ツールをクリックします。
- 以下のようにパラメーターを設定し、[実行] をクリックします。
- [入力フィーチャ]: 対象のポリゴン
- [出力フィーチャクラス]: 出力されるデータの保存先、名前
- [ポリゴン隣接情報を特定して格納]: オフ

Basic ライセンスの場合
ポリゴンをコピーして、ラインに貼り付ける方法
- [フィーチャクラスの作成] ツールを使用して、あらかじめ、ポリゴンと同じ座標系を持った空のラインを作成します。
- [編集] タブ → [選択] ツールをクリックします。

- コピー元のポリゴン フィーチャを選択します。
- [編集] タブ → [コピー] をクリックします。
- [貼り付け] の下のドロップダウンをクリック → [形式を選択して貼り付け] をクリックします。
- [貼り付け先] が手順 1 で作成したラインになっていることを確認し、[OK] をクリックします。

※ [OK] をクリック後、[移動] ツールが自動的に実行されますが、貼り付けられたラインを移動しない場合は、閉じてください。
[移動] ツールが自動的に実行される設定をオフにするには、「フィーチャを貼り付けた後で移動ツールを実行」をご参照ください。
- [編集] タブ → [保存] をクリックし、編集を保存します。

[インターセクト] ツール、[ディゾルブ] ツールを使用して、ポリゴンからラインを作成する方法
- [解析] タブ → [ツール] をクリックして [ジオプロセシング] ウィンドウを表示します。
- [ジオプロセシング] ウィンドウ上部にある [ツールの検索] で「インターセクト」と検索し、[インターセクト] ツールをクリックします。
- 以下のようにパラメーターを設定し、[実行] をクリックします。
- [入力フィーチャ]: 対象のポリゴン (2 つ)
- [出力フィーチャクラス]: 出力されるデータの保存先、名前
- [出力タイプ]: ライン

実行後、ポリゴンの枠線が作成されます。ただし、1 つのポリゴンを構成するラインが複数に分けて作成されていますので、ラインを集約します。
- [ジオプロセシング] ウィンドウ上部にある [ツールの検索] で「ディゾルブ」と検索し、[ディゾルブ] ツールをクリックします。
- 以下のようにパラメーターを設定し、[実行] をクリックします。
- [入力フィーチャ]: 手順 3 で作成したライン
- [出力フィーチャクラス]: 出力されるデータの保存先、名前
- [ディゾルブ フィールド]: フィーチャを集約するフィールド

「サンプル ジオプロセシング ツール」を使用する場合
- ESRIジャパンが公開しているサンプル ジオプロセシング ツールボックス の EJPyConv ツールの [ポリゴンをラインへ変換] ツールを使用して、ポリゴンからラインを作成します。
- EJPyConv ツールの [ポリゴンをラインへ変換] ツールを使用するには、EJPyConv ツールをダウンロードした上で、ArcGIS Pro にフォルダーを追加する必要があります。
- EJPyConv ツールの ダウンロードおよび ArcGIS Pro への追加方法は、EJPyConv setup wiki – ArcGIS Pro への設定方法をご参照ください。
- EJPyConv ツールのフォルダーを追加した状態で、[カタログ] ウィンドウ → [フォルダー] → [EJPyConv] → [EJPyConv.tbx] → [ジオメトリ操作] → [ポリゴンをラインへ変換] をクリックします。

- 以下のようにパラメータを設定し、[実行] をクリックします。
- [入力フィーチャ]: 対象のポリゴン
- [出力フィーチャクラス]: 出力されるデータの保存先、名前

免責事項
- 本ツールボックスに含まれるジオプロセシング ツールはサンプルとして提供しているものであり、動作に関する保証、および製品ライフサイクルに従った Esri 製品サポート サービスは提供しておりません。
- ツールボックスに含まれるジオプロセシング ツールによって生じた損害等の一切の責任を負いかねますのでご了承ください。
- 弊社で提供しているEsri 製品サポートサービスでは、本ツールに関しての Q&A サポートの受付を行っておりませんので、予めご了承の上、ご利用ください。詳細は「ESRIジャパン GitHub アカウントにおけるオープンソースへの貢献について」をご参照ください。
このナレッジはお役に立ちましたか?
フィードバックをいただきありがとうございます!