概要
地層の境界面などを断面図で表したい場合は、[フェンス ダイアグラム] ツールにて行うことができます。断面図はマルチパッチで出力されます。
※本機能は ArcGIS Pro 2.1 からの機能です。
※3D Analyst エクステンション製品が必要です。
断面図の例

手順
- [ジオプロセシング] ウィンドウ → [ツールボックス] → [3D Analyst ツール] → [3D 交差] → [フェンス ダイアグラム (Fence Diagram)] ツールを実行します。
- 以下の設定を行います。
[入力ライン フィーチャ]: 断面図のラインレイヤー
[入力サーフェス]: 複数の境界面となるレイヤー
[出力マルチパッチ フィーチャクラス]: 断面図のマルチパッチ レイヤー

- [実行] をクリックします。
- 断面図を境界面ごとに色分けします。
[コンテンツ] ウィンドウ → 断面図 マルチパッチ レイヤーを選択します。
ArcGIS Pro → [フィーチャレイヤー] タブ → [描画] グループ → [シンボル] ボタンをクリックしますと、[シンボル] ウィンドウが表示されます。

- [シンボル] ウィンドウで以下の設定を行います。
[シンボル]: 個別値
[値 フィールド]: (例)Top / Bottom
[配色]: 任意のカラーランプ

応用例
複数の掘削地点のデータ(X、Y、Z値)から地層境界面のポイントレイヤーを作成したあと、内挿処理にて地層境界面を作成して、断面図を作成します。
- ポイントレイヤー作成については「XY座標値からポイントを作成する」 をご参照ください。
- 内挿処理については関連情報 「ArcGIS ユーザーのための内挿法ガイド」 をご参照ください。
このナレッジはお役に立ちましたか?
フィードバックをいただきありがとうございます!