説明
ArcGIS Pro でのフィールドの追加・削除の方法を説明します。
ジオプロセシング ツールを使用する方法
フィールドの追加
1 つのフィールドを追加する場合
[ジオプロセシング] ウィンドウ → [ツールボックス] → [データ管理ツール] → [フィールド] → [フィールドの追加] ツール
複数のフィールドを追加する場合
[ジオプロセシング] ウィンドウ → [ツールボックス] → [データ管理ツール] → [フィールド] → [フィールドの追加 (複数) ] ツール
フィールドの削除
[ジオプロセシング] ウィンドウ → [ツールボックス] → [データ管理ツール] → [フィールド] → [フィールドの削除] ツール
テーブルから行う方法
フィールドの追加
- [コンテンツ] ウィンドウで対象レイヤーを右クリックし、[属性テーブル] をクリックして属性テーブルを開きます。
- 属性テーブル上部にある [追加] をクリックします。

- [フィールド名] や [データ タイプ] などを設定します。

・[フィールド名]:作成するフィールドの名称を入力してください。
・[データ タイプ]:[Short]、[Long]、[Double] 等を選択してください。
(種類)- Short ─ Short integer(16 ビット)
- Long ─ Long integer(32 ビット)
- Float ─ 単精度浮動小数点型
- Double ─ 倍精度浮動小数点型
- Text ―文字列
- Date ─ 日付と時刻のデータ
※フィールド名には制限事項があります。詳細は「テーブルのフィールド名およびテーブル名に関する制限事項」をご確認ください。
データ タイプの詳細は「ArcGIS データ タイプ」をご確認ください。
- 編集が完了したら、[フィールド] タブの [保存] をクリックします。

バージョン1.3.1 以上、Basic ライセンスをお使いの場合、シェープファイルでは [追加] ボタンをクリックしても新規フィールドが作成されないことがあります。
その場合は、ジオプロセシング ツールの [フィールドの追加] ツールを使用するか、ファイル ジオデータベースのフィーチャクラスに変換後、テーブルからフィールドを追加してください。
フィールドの削除
ArcGIS Pro 3.6 以降をご利用の場合
属性テーブルを開き、削除したいフィールド名上で右クリック → [削除] をクリックします。

ArcGIS Pro 3.5 以前をご利用の場合
属性テーブルを開き、削除したいフィールド名上で右クリック → [削除] をクリックします。
または、削除したいフィールド名をクリックし選択状態にした後、属性テーブル上部にある [削除] をクリックします。
このナレッジはお役に立ちましたか?
フィードバックをいただきありがとうございます!