ESRIジャパン株式会社

ArcGIS Pro: ネットワーク解析の基本操作

ナレッジ ID: 22718 | 公開日: 2023年5月29日 | 更新日: 2026年10月8日

概要

ArcGIS Pro でネットワーク解析(到達圏、ルート、最寄り施設の検出、ロケーション・アロケーション、OD コスト マトリックス )を行う際の基本操作手順をご紹介します。

手順

  1. [解析] タブ → [ネットワーク解析] をクリックします。
  2. [ネットワーク データ ソース] で、解析に使用する道路網データを選択します。
    表示されていない場合は、[参照] ボタンから追加してください。

<道路網データの種類>

道路網データ特徴解析に必要なエクステンションクレジットの消費
ArcGIS Online (https://www.arcgis.com)
※デフォルト設定
・ArcGIS Online で提供されている道路網データです。世界の大部分の道路情報が含まれていますが、国・地域によってデータ精度は異なります。詳細は「ネットワーク解析の有効範囲」をご参照ください。
・ご利用にはインターネット接続が必要です。
なしあり
ArcGIS Geo Suite 道路網・ESRIジャパンが有償で提供する交通規制情報付きの道路ネットワーク データセットです。
・道路種別や道路規制などの詳細な道路情報が含まれており、ネットワーク解析時に活用できます。 詳細は「道路網 (ArcGIS Geo Suite)」をご参照ください。
Network Analystなし
自作のネットワーク データセット・ネットワーク解析で使用される道路網データは、「ネットワーク データセット」形式で作成されます。
・Network Analyst エクステンションをご利用の場合は、ArcGIS Pro でお客様独自のネットワーク データセットを作成できます。
Network Analystなし
  1. 解析ツールを選びます。
    ※使用する解析ツールによって必要なパラメーターが異なります。ここでは [到達圏] ツールを例に説明します。
  2. 解析に必要な施設ポイントなどを設定します。

    設定方法 1: 既存のポイント データを読み込む
    [到達圏レイヤー] タブ → [施設のインポート] から、事前にご用意いただいたポイント データを読み込みます。


    設定方法 2: マップ上で施設ポイントを作図
    [編集] タブ → [作成] をクリックします。
    [フィーチャ作成] ウィンドウにて [到達圏: 施設] のポイントをクリックし、マップ上にポイントを作成します。
    作図完了後は、[編集] タブ → [保存] で編集を保存します。
  1. [到達圏レイヤー] タブ → [移動モード] グループで [モード] や [カット オフ] などのネットワーク解析の設定を行います。
  2. [コンテンツ] ウィンドウ → [到達圏] を右クリック → [プロパティ] で更に詳細な設定を行います。
    よく利用される設定は、[移動モード] 内にある [タイプ] や [コスト] のインピーダンス(時間や距離) などです。
  3. [到達圏レイヤー] タブ → [実行] で解析を行います。

Error 000626 について

道路網データや自作のネットワーク データセットを使用したネットワーク解析を行う場合は、Network Analyst エクステンションが必要です。Network Analyst エクステンションのライセンスをお持ちでない際は、以下のエラーが表示されます。

[プロジェクト] タブ → [ライセンス] を開き、[Network Analyst] エクステンションが有効かご確認ください。

このナレッジはお役に立ちましたか?

はい
いいえ
フィードバックをいただきありがとうございます!